A vulnerability in the latest Java 7 runtime has been discovered that can be exploited and used for malicious attacks, Computer World reported. While all the reported exploits thus far have targeted Windows PCs, according to Errata Security CTO David Maynor, both Mac and Linux computers are just as vulnerable to attacks. “This exploit works on OS X if you are running the 1.7 JRE [Java Runtime Environment],” said Maynor, who was able to exploit the vulnerability in both Firefox 14 and Safari 6 on OS X 10.8. The exploit is considered “super dangerous” and could compromise a computer simply by browsing a malicious or hacked website.Computer World suggests that users disable Java until Oracle (ORCL) releases a patch to address the problem.

Read

Dan joins the BGR team as the Android Editor, covering all things relating to Google’s premiere operating system. His work has appeared on Fox News, Fox Business and Yahoo News, among other publications. When he isn’t testing the latest devices or apps, he can be found enjoying the sights and sounds of New York City.