WhatsApp is one of the most popular messaging apps on smartphones today, and it’s available on virtually every mobile operating system. Because of that, the app has to pick and choose when to drop support for various versions of each individual OS. Earlier in 2016, the company announced which specific versions it would be dropping by the end of 2016, but it has since adjusted its forecast slightly. Here are the smartphones and OSes that will be dropped starting “at the beginning of 2017.”

MUST READ: Get ready to hate Zynga all over again

Phones:

  • iPhone 3GS

OS versions:

  • iOS 6
  • Android 2.1
  • Android 2.2
  • BlackBerry OS
  • BlackBerry 10
  • Nokia S40
  • Nokia Symbian S60
  • Windows Phone 7

“These platforms don’t offer the kind of capabilities we need to expand our app’s features in the future,” WhatsApp posted on its blog. “If you use one of these affected mobile devices, we recommend upgrading to a newer Android running OS 2.3+, a Windows Phone 8+, or an iPhone running iOS 7+ before the end of 2016 to continue using WhatsApp.”

It’s certainly within reason to think that iOS 6 and the iPhone 3GS are both a bit too long in the tooth to support additional app updates, and the same is likely true for the aging Android versions 2.1 and 2.2.

However, it’s somewhat humorous that the company suggests that BlackBerry 10 is too outdated to support the WhatsApp platform, considering the operating system is still under active development. It’s probably safer to assume there’s just not enough WhatsApp users on BlackBerry to make the development investment, though the company would never come out and actually say such a thing.

Comments