Apple on Monday unveiled OS X El Capitan, its next major update for Macs. The OS brings several performance improvements and new features to the desktop, and Mac users will be able to install it on MacBooks, iMacs and other OS X computers as soon as this summer when the first OS X 10.11 beta will be released. But what are the system requirements for running El Capitan?

DON’T MISS: Apple Music has a secret weapon that almost no one’s talking about

Online tips blog OS X Daily has listed the system requirements and compatible Macs that can run El Capitan. Unsurprisingly, the same laptops and desktops that are on Yosemite now will be able to run El Capitan when it arrives this summer (beta version) or fall (final software release).

The list of El Capitan compatible Macs includes the following models:

  • iMac (Mid-2007 or newer)
  • MacBook (13-inch Aluminum, Late 2008), (13-inch, Early 2009 or newer)
  • MacBook Pro (13-inch, Mid-2009 or newer), (15-inch, Mid / Late 2007 or newer), (17-inch, Late 2007 or newer)
  • MacBook Air (Late 2008 or newer)
  • Mac Mini (Early 2009 or newer)
  • Mac Pro (Early 2008 or newer)
  • Xserve (Early 2009)

When it comes to system requirements, the blog says that the better the hardware, the smoother the experience users should get. As long as your Mac has a 64-bit CPU, you should be able to run El Capitan, OS X Daily says, adding that “beyond that, the requirements are pretty soft and forgiving.”

However, Apple is focusing this year on making OS X run even smoother on older devices than previous releases, just like it does with iOS 9 for iPhones and iPads.

View Comments